Back to forum.wakfu.com

No flash

Lag getting worse?
Not so Hairy Moon * Member Since 2012-01-22
posté December 16, 2013, 05:29:33 | #1
Lag getting worse? When you play this game for a while, you start getting short freezes. The game will jam for about a second and then resume. This seemingly happens to everyone, and only gets worse as time goes on. I don't know if it's memory leaks or poor coding, but it's been with us forever.

Lately however, it seems to be getting worse and worse. I remember having to restart clients after 3 hours of play or so before it gets unbearable. Now it takes no less than 30-45 minutes. Before and after a dungeon, after 2-3 fights.

Is it just me? Does anyone know a solution? Is it being worked on?


Speechless Crobak * Member Since 2012-01-05
posté December 16, 2013, 06:23:50 | #2
What OS are you using? o.o


Scary Polter * Member Since 2012-01-17
posté December 16, 2013, 06:56:48 | #3
I've always had this problem. It used to be 3-4 hours of gametime for me and now I notice it after 1-2 hours.

My new computer(built within the last 2 weeks) can handle the ridiculous amounts of memory leaks, much better than my laptop so it is not as bad, its more of just mini freezes, I can tell because the gameplay sounds usually lags (which is what i think it is because this is similar to a problem i had on runescape years ago)

I've basically come to the conclusion that is it indeed poor/lazy/sloppy coding.

Im using Windows 7


This post has been edited by MoshPitt - December 16, 2013, 06:57:28.
Not so Hairy Moon * Member Since 2012-01-22
posté December 16, 2013, 07:00:26 | #4

Quote (Intrade @ 16 December 2013 06:23) *
What OS are you using? o.o
Windows 7


Community Helper * Member Since 2013-01-14
posté December 16, 2013, 07:06:50 | #5
Yeah I've been experiencing this as well. I had it a little bit, occasionally, but then came the Java update. I was originally playing on a Mac but very recently upgraded and now I use Windows 8. I originally picked Wakfu because it used to use so little internet, but now its just a big internet-absorbing sponge. My client freezes pretty often and I get super lag after an hour or so of playtime (on a brand new computer mind you). I don't know what it is, but it really is getting worse. I've seen a whole bunch of topics in the Technical Issues sub forum about it, and it doesn't seem anyone has anything to say about it.


Ecstatic Whisperer * Member Since 2012-04-04
posté December 16, 2013, 07:55:05 | #6
I'm having this problem since the java update. Really annoys and demotivates me.. Even worse, one of my buddies who left the game a while ago and had a chance to return looked at this freezing and lagging sh*t and of course didn't want to return.


Ambitious Crackapult * Member Since 2006-01-31
posté December 16, 2013, 08:06:07 | #7
Been having these exact issues since the Java update. Used to play for hours without being interrupted by lag, now I can't even log on without my game freezing up for a second.

Every time I shut the game down, I have a little less inclination to boot it back up again. Would be nice if they kept that to an absolute minimum  


Wilder than Wild Dragoturkey * Member Since 2012-03-02
posté December 16, 2013, 08:32:41 | #8
I have been experiencing the same problem.

I've also been noticing an increase in lag, patch after patch. I'm the point where I have to restart my clients every 30 mins as well.

I'm not going to say it's been occurring since Java update as this has been a known issue for a while, but it has been getting worse.


Ambitious Crackapult * Member Since 2006-01-31
posté December 16, 2013, 08:38:50 | #9

Quote (Fadedscourge @ 16 December 2013 08:32) *
I have been experiencing the same problem.

I've also been noticing an increase in lag, patch after patch. I'm the point where I have to restart my clients every 30 mins as well.

I'm not going to say it's been occurring since Java update as this has been a known issue for a while, but it has been getting worse.

Ah, when we say it's been "since the java update", that's just when it really kicked in. It was always present but it always took several hours to stir up, whereas right now it's - like you said - faster than Dominos.


Grizzled Dandelion * Member Since 2012-04-09
posté December 16, 2013, 10:16:02 | #10
Me too. After several hours of play lags increase so I have to restart the client. It's always been so even before any recent updates. And of course there're those small freezes while opening almost any menu, entering\exiting HB, using Dragoturkey, opening world map etc. It happens even if I play with single client running. And I wouldn't say that my PC is too weak for Wakfu.


Nun Shall Pass * Member Since 2012-07-03
posté December 16, 2013, 11:13:55 | #11
Lagging all the time.

Even when my internet speed test isn't reading poorly.


Ambitious Crackapult * Member Since 2012-03-04
posté December 16, 2013, 13:19:51 | #12
Yeah, it's gone so laggy ever since the java update, same on my end. I thought it was only me ^^; glad this thread popped up!


Grizzled Dandelion * Member Since 2011-12-17
posté December 16, 2013, 14:29:47 | #13
Pretty much confirming all of what has been said. From my experience it seems to be a vicious circle of memory leakage that Ankama has never managed to shake off. It was the same after major Dofus updates as well, I imagine it still is. While memory leaks are always present, they tend to make them far more noticeable with big updates (be it content or in this case, the java update). Eventually they'll patch it up until the next big update rolls in and so on. It's the gift that keeps on giving.  


Lord Madgobb * Member Since 2011-12-11
posté December 16, 2013, 16:15:15 | #14
I really hope they fix it soon. I have this issue and when playing certain classes like Xelor it's troublesome to say the least. If i don't have my actions decided before my turn starts i can't use all my AP. I need every second to get through the animations. It affects how much i enjoy the game.


Narcissistic Larva * Member Since 2013-11-13
posté December 16, 2013, 16:17:51 | #15
What Ive noted was that loading the maps as you move your character around, possibly the maps or elements on the map do not unload after leaving said area, could be intentional so if you return to this area shortly then the game will not have to load this area again. Anyways, the more I move my character around the more memory leakage/lag I get. If I stay at haven world, I can be there for hours. Going to the market to check on something is a death sentence for contenuace play. Sadly most gaming companys find this as a very bad thing. Players be like "Oh I have to restart the client, or the whole computer... should I log back in after I close the game?"


Lord Madgobb * Member Since 2011-12-11
posté December 16, 2013, 19:12:11 | #16

Quote (Celover @ 16 December 2013 16:17) *
What Ive noted was that loading the maps as you move your character around, possibly the maps or elements on the map do not unload after leaving said area, could be intentional so if you return to this area shortly then the game will not have to load this area again. Anyways, the more I move my character around the more memory leakage/lag I get. If I stay at haven world, I can be there for hours. Going to the market to check on something is a death sentence for contenuace play. Sadly most gaming companys find this as a very bad thing. Players be like "Oh I have to restart the client, or the whole computer... should I log back in after I close the game?"

Good points, i never considered some of those reasons. I usually have a character at the market for quite some time before i start running any dungeons etc. I'll have to try a different approach and see if it helps.

Any idea if simply closing my client and launcher helps? Or would I need to restart my whole PC to clear up the memory?


Narcissistic Larva * Member Since 2013-11-13
posté December 16, 2013, 19:37:18 | #17
I always just restart my comp, some people say restarting the client works, but it takes like a minute for client window to close, then the music contenues (Still running in the background) for several minutes, if I force close it, I have to restart comp anyways. so it is faster, for me, to restart the comp.


Edit:Altho I assume if you dont want too long between restarting the client, maybe it wont be sooo laggy and get stuck in the background. Or possibly one of my service settings is inflicting this problem, or my comp just sucks n_n


This post has been edited by Celover - December 16, 2013, 19:40:42.
Eccentric Moogrr * Member Since 2011-10-31
posté January 19, 2014, 17:26:29 | #18
Is Ankama even aware of the "mini"-freezes since the update and is removing this on the to-do-list?

It's really annoying and many players are affected by it..


Teethless Sharkie * Member Since 2013-05-06
posté January 19, 2014, 18:35:25 | #19
I've been noticing a lot more disconnecting during fights too, as well as a few second delay when casting spells these last few days. Move to a new cell --> wait 3 seconds ---> animation plays ---> line up spells and cast them ---> wait 3 seconds ---> animation plays for one ---> wait 3 seconds ---> animation plays for second ---> wait 3 seconds ---> animation plays for third ---> etc.
It's ridiculous, and tedious. I've never had that issue until this week's patch.
Fortunately, the game is still playable, for now.


Short Strich * Member Since 2012-04-24
posté January 19, 2014, 18:51:17 | #20
Its nice how it freezes at the end of magmog/necro dungeon fights